Talkspirit is compatible with the following browsers and their more recent versions:

  • Chrome 72+ (January 29, 2019)

  • Firefox 65+ (January 2019)

  • Edge 79+ (January 2021)

  • Safari 12+ (July 2021)

Without warranty:

  • Chrome 49+

  • Firefox 50+

  • Safari 10+

  • EDGE 16

Did this answer your question?