Talkspirit is compatible with the following web browsers:

  • Chrome 49+ (release: 2016/3/2)
  • Firefox 50+ (release: 2016/11/15)
  • Safari 10+ (release: 2016/9/20)
  • EDGE 16 (release: 2017/09/26)

Without warranty:

  • Chrome 29+
  • Firefox 37+
  • Safari 9+
  • EDGE 14+
  • IE11
Did this answer your question?